top of page

Money & Abundance Workshop Group

Public·7 members

Install Oracle Forms Reports 12.2.1.4 With Weblogic 12c 12.2.1.4 |BEST|


Dear.which version virtua C+ use for 12.2.1.4?i tried use c+ 2010, 2012.. but received alert: version not right when install form&report.And when installed done, i can not start OHS.pls give me version and link to download it.thank you.hope hear you soon




Install Oracle forms reports 12.2.1.4 with Weblogic 12c 12.2.1.4



Have you tried installing 12c 12.2.1.4 weblogic and 12.2.1.4 (forms and reports) on windows server 2019 ?Last I have installed 12.2.1.4 on windows 2012 and 2016 and its working perfectly since 3 years.But I want to upgrade the OS to 2019 but I am facing EM, Console and others command line weblogic start/stop , manage server start/stop is hanging without any errors.


Hi,I'm upgrading forms & reports from 11.1.2.1 to 12.2.1.4 and have got some questions about my developer installation. Hope someone can help.While IT is preparing both a development 19c database linux server and a weblogic 12.2.1.4 linux server, I'm starting setting up my development desktop windows 10.First I tried the forms builder standalone, but as it doesn't include reports builder, I uninstalled and now will try to go with the standard installation.I see weblogic (local weblogic) is a prerrequisite. In the weblogic download page there are quite some options for 12.2.1.4: generic, slim, quick installer, infrastructure, another generic (with ADR?) ... which one should I install?


When installing Forms and Reports 12.2.1.4.0 an error exception is received in the Oracle Universal Installer (OUI) log indicating that the overall result of this check is: FailedThe below error is observed:


So that seems simple and straightforward enough, the part where I get confused is ... what do we need to do BEFORE the upgrade? I'm assuming I need to download and install the Fusion Middleware Infrastructure (fmw_12.2.1.4.0_infrastructure.jar), and also Forms/Reports 12.2.1.4 (setup_fmw_12.2.1.4.0_fr_win64.exe). However, once the infrastructure is installed do I need to install and configure WebLogic within that new install or perform any configuration steps or can I just jump into the above link and start the upgrade process (reconfigure the existing weblogic domain and then run the upgrade assistant)? I know I need to install the required schemas via RCU for the 12 infrastructure (requirement to reconfigure an existing WebLogic domain) but is there anything else not mentioned in the upgrade steps that are relied upon and assumed done in the installation steps?


As of October 2021, there are a few different versions of Java SE currently available for public use. Examples include Java SE 8, Java SE 11, and Java SE 17, the most current release available. Oracle has recently released the next version of Java SE, version 17, this month. With all of the different releases of Java SE available in addition to archived releases such as Java 6 and 7, which are the Java versions supported with Oracle Forms 12.2.1.4.0?


Currently, Oracle Forms 12.2.1.4.0 is the latest and greatest release of Oracle Forms available for consumers from Oracle. As of today, there are no dates set in stone for when Oracle will release the next version of Oracle Forms. Forms 12.2.1.4.0 is currently covered under premier support from Oracle until December 2023. However, this date may always change depending on when Oracle releases a new version of Oracle Forms. With this in mind, these are the following Java versions supported with Oracle Forms 12.2.1.4.0 at this time. Please note that Java SE represents Oracle JDK, Oracle JRE, or both. For any of the Java SE releases not currently supported, we will discuss if these versions could be supported in the future or why they may not be supported:


Oracle Forms 12.2.1.4.0 is not currently supported with Java SE 7, and Java 7 will not be supported in the future. The reason is that Java 7 has ended premier support back in July 2019. It is advised that all users who are using Java 7 for anything should consider looking into upgrading to at least Java 8.


Oracle Forms 12.2.1.4.0 is supported with Java 8 Update 211 or higher for both the Oracle JDK and the Oracle JRE. This applies to all methods of running Oracle Forms: using the web browser with an NPAPI plugin, Java Web Start (JWS), or Forms Standalone Launcher (FSAL). Please keep in mind that Java 8 is planned be the last release that will have JWS available. At that point, Oracle will advise that all Oracle Forms users will need to switch over to FSAL when running Oracle Forms. Java 8 is currently available under premier support until March 2022. However, Oracle has stated in My Oracle Support Doc ID 2440615.1 that Java 8 will continue to be available for updates and support as long as Oracle Forms 12c is covered under support.


Oracle Forms 12.2.1.4.0 is not supported with either Java SE 9 or Java SE 10, and Forms will never be supported with Java 9 and Java 10. Java 9 and Java 10 were only short-term releases and were taken out of support on March 2018 and September 2018 respectively.


Oracle Forms 12.2.1.4.0 has limited supported with Java 11 (11.0.4+). It is only supported with JDK 11.0.4 or higher when using Forms Standalone Launcher only per the Oracle Fusion Middleware Certification Matrix for 12.2.1.4.0. Java 11 is not supported when running Oracle Forms 12.2.1.4.0 with the traditional NPAPI plugin (only available with Internet Explorer) or with Java Web Start. The reason is that a JRE is required to use the web browser or Java Web Start for launching Forms applications. Java 11 does not come bundled with a JRE; only a JDK is available. As a long-term release, Java 11 is currently available under premier support through September 2023. If you are interested in implementing FSAL for running Oracle Forms 12c, please visit our article for more information on how you can set up FSAL.


Oracle Forms 12.2.1.4.0 is not supported with Java SE 12, Java SE 13, Java SE 14, Java SE 15, or Java SE 16. Java 12, 13, 14, 15, and 16 were only short-term releases and were taken out of support on September 2019, March 2020, September 2020, March 2021, and September 2012 respectively.


Oracle has released Java SE 17 in October 2021. Oracle Forms 12.2.1.4.0 has limited supported with Java 17. It is only supported with JDK 17.0.1 or higher when using Forms Standalone Launcher only per the Oracle Fusion Middleware Certification Matrix for 12.2.1.4.0. Java 17 is not supported when running Oracle Forms 12.2.1.4.0 with the traditional NPAPI plugin (only available with Internet Explorer) or with Java Web Start. The reason is that a JRE is required to use the web browser or Java Web Start for launching Forms applications. Java 17 does not come bundled with a JRE; only a JDK is available. It will be covered under support until possibly September 2026. If you are interested in implementing FSAL for running Oracle Forms 12c, please visit our article for more information on how you can set up FSAL.


Now with YaK weblogic_domain component, we are able to deploy WebLogic domains clustered or not, Fusion Middleware Forms & Reports, Fusion Middleware infrastructure for ADF applications to on-premises platforms, or on different platforms on the Cloud (AWS, Azure, OCI). YaK core takes care of the infrastructure and Yak WebLogic_domain component takes care of the WebLogic or Fusion Middleware applications servers.


INST-07551: Not all dependent featuresets for install type "Forms andReports Deployment" could be found. The following prerequisites werefound to be missing: em_fmc - 12.2.1.4.0wls_server - 12.2.1.4.0Select a different Oracle Home having all dependencies. Check =fmw122140&id=installhomefor details about compatible products and install types.


It becomes hectic and time consuming to start and stop these services one by one. To ease the entire startup/shutdown process we can create services for Nodemanager, weblogic admin server , forms ,reports. 350c69d7ab


About

Welcome to the group! You can connect with other members, ge...